Light Map Maker 0.3 Manual

 


Introduction
Light Map Maker is a powerful tool that creates compelling lighting effects quickly. Although easy and simple it is a fully professional application for game and simulation creation. By using it, you can easily achieve professional lighting in real-time 3D scenes. It also has geometry processing and light map tailoring (finding disorganized triangles to surfaces). This ability is especially useful for those scenes modeled with the standard 3D programs (3dsmax, maya, etc). The resultant lighting data can be directly saved to BMP or Radiance files, or outputted to custom format file through Export-Plugins. So read this following manual and get to the fun fastest.


Glossary
This section introduces some of the concepts that Light Map Maker uses to describe 3d components.


Vertex:
A vertex is a single point in 3d space. It's specified by three coordinates x, y and z.

Triangle:
A basic unit, composed of a mesh, determined by three vertices.

Mesh:
A triangle list.

Surface:
A series of connected triangles; all triangles in one plane. You can consider it a special mesh.

Terrain:
A Mesh, but unlike Surface, not requiring all triangles to be coplanar. Terrain is used to represent outdoor scenes because usually the area of triangles is much greater in outdoor scenes, so the lighting for "Terrain" is not base surface, but vertices. This reduces the file size of the lighting data.

Mobile:
A Mesh for those movable objects in scenes. Mobile can has it's Material. You not need (couldn't) calculating mobile's lighting, because it's lighting is realtime. Mobile is a helper for casting shadow, radiosity bake and caustics.

Material:
Materials describe how polygons reflect light or appear to emit light in a 3-D scene. Essentially, a material is a set of properties that explain the following things about the polygons it is rendering.
         1. How they reflect ambient and diffuse light
         2. What their specular highlights look like
         3. Whether the polygons appear to emit light

Light:
Lights are used to illuminate objects in a scene. The current version of Light Map Maker employs  three types of lights: point lights, spotlights, and directional lights.

Point Lights:
Point lights have color and position within a scene, but no single direction. They radiate light equally in all directions. Point Lights are also sometimes called omni lights. A light bulb is a good example of a point light. Point lights are affected by attenuation and range. Attenuation controls how a light's intensity decreases toward the maximum distance specified by the range property. Light Map Maker applies the following formula to calculate light attenuation over distance for point lights and spotlights (directional lights don't attenuate).

In this attenuation formula, A is the calculated total attenuation and D is the distance from the light source to the sample point. Attenuation0, Attenuation1, and Attenuation2 values are the light's attenuation constants.

Spotlights:
Spotlights have color, position, and a direction in which they emit light. Light emitted from a spotlight is made up of a bright inner cone and a larger outer cone, with the light intensity diminishing between the two. A flashlight is a example of a spot light. Spotlights are affected by falloff, attenuation, and range. The light parameter Theta controls the inner cone, Phi controls outer cone, and Falloff controls the light intensity graduations from inner cone edge to outer cone.

Directional Lights:
Directional lights have only color and direction, not position, are not affected by attenuation or range. They emit parallel light. This means that all light generated by directional lights travels through a scene in the same direction. Imagine a directional light as a light source at near infinite distance, such as the sun.

Light Map:
A light map is a texture or group of textures that contains information about lighting in a 3D scene.

base texture lightmap lighting effect


Patch Size:
Describes sample space of lighting calculation on surface. Smaller patch sizes carry more detailed lighting, but increase light map size.

Mirror:
A surface that has Reflection property.

Light Map Maker Operation

1. Load or Import Mesh (surface, light), automatically generate surfaces by program.

There are two ways to input meshes:
(1) Select Load Mesh... or Append Mesh... from the File menu and use the standard Windows file open dialog that appears, open a (.tri) file. (.tri) file can be produced through exporting from other 3D modeling software. The current version of Light Map Maker offers a export plug-in for 3dsmax4("max4triexp.dle") which can be found in Light Map Maker's "otherplugins" folder. You must copy it into 3dsmax's plugins folder if want to use it.
(2) Select Import... from the File menu, and get mesh data (for any file format with a corresponding plug-in from LMM's plugins folder). The current version of Light Map Maker offers a import plug-in for Direct3D X files (More Plugins). Its source can be found in LMM's "source" folder. You can modify it implement other formats.

2. Position the lights, compute lighting, and adjust to taste, and just hit Start!

Now there are some surfaces in your scene, the next step is to add lights. To create a light, click on the "Create" button at the toolbar, then left-click in view window. You can now modify any light's properties in control panel (default on the left), and can also move/rotate/scale lights by clicking the corresponding button on the toolbar and dragging in the view window. Finally choose Calculate Light Maps... from the Edit menu (or press F9). Then wait a moment for the lighting effect to appear in your viewport. 

3. Export your finished file.

Select Save Light Maps... from the File menu. You can save the light map images to bitmap format. Select Export... from the File menu. You can export scene data that way. The current version of Light Map Maker offers a plug-in to convert exported scene data to ASCII format (.txt, .tse). If you want to export to own format, you could write a custom plug-in; a sample of which can be found in Light Map Maker's "source" folder. Export your new LMM generated surfaces, lights and light map images for easy use in your realistic real-time 3D scenes.

 

Toolbar Explanation:

 

1: Load Scene (Ctrl+O) 2: Save Scene (Ctrl+S) 3: Cut (Ctrl+X)
4: Copy (Ctrl+C) 5: Paste (Ctrl+V) 6: Undo (Ctrl+Z)
7: Hold (Ctrl+H) 8: Fetch (Ctrl+F) 9: Texture Mode (Shift+T)
10: Properties (Alt+Enter) 11: List Objects (H) 12: Move Camera (M)
13: Zoom Camera (Z) 14: Rotate Camera (A) 15: Select (Shift+L)
16: Create (Shift+C) 17: Move (Shift+M) 18: Rotate (Shift+R)
19: Scale (Shift+S) 20: View Select 
(T:top,B:bottom,L:left,R:right,F:front,K:back)
21: Restrict to axes
22: Look At Selection (Shift+Z) 23: Look At All (Shift+A) 24: Lock Selection (Space)
25: Align 26: Hide (Shift+H) 27: Unhide

Texture Operation:

1: Fit  2: Tile 3: Flip along U vector 4: Flip along V vector 5: Exchange UV 

6: Rotate 90 degrees along clockwise  7: Rotate 90 degrees along counter-clockwise

8: Change Texture Parameter  9: Map Texture along the surface plane

Lock tab: Lock current tab page. When you select a object in scene, the program will auto-switch the corresponding tab page by default.

Add Texture: Load a texture into scene from image file.

Delete Texture: Delete current texture.

Remove All: Clear all textures in scene.

Show File Name: Show image file path of current texture.

Zoom: Zoom images.

Common Images: Show base textures in scene.

Lightmaps: Show light maps used by scene.

 

Light Map Options:

Ambient: The ambient color in lighting calculation

Background: The back color of lightmap image, not related to lighting calculation.

Image Width, Image Height: The lightmap image resolution

Sample spacing: The Patch Size of surfaces namely, see Light Map Maker concepts above.

Lightmap Number: When the number is 0,the lightmap image number is determined by Sample spacing and Image Width & Height; When the number is >0,the program will rectify the Patch Size of surfaces in order to limit the lightmap image number.

Cast shadow: Specifies whether to take into account shadows in ray tracing lighting calculation.

Mirror Lighting: Specifies whether take into account mirrors in ray tracing lighting calculation.

Save float data: Specifies whether to save the float lighting data to disk file. Disabling this function will economize on disk space and the time of saving/loading scene file, but the Expose command function (in 'Post process') will become unusable if you do choose the no-float-lighting-data-saving setting. 

Brightness rectification: Adjust the lightmap images brightness. It's image process only.

Blur: Specifies blurring of the bitmap image. It's a simple antialiasing method.

Expose: Control the lighting data conversion from FLOAT to BYTE. The formula for the conversion is float data  X  Expose Value.

Exposure coefficient: Control the Exposure of radiosity lighting calculation.

Render resolution: The render resolution of the radiosity solution. More resolution yields more detail, but of course far more render time too.

Curtness Mode: The Curtness Mode of radiosity can save a lot of computer time but it's imprecise.

 

Miscellaneous Options:

Number of undo buffers: The maximum numbers of undos.

Measure: Adjust all measurement parameters.

Coplanarity error: The precision to confirm two faces is coplanar.

Step of camera move: Controls the minimum increments of moving when navigating in 3D space.

Step of camera rotate: Controls the minimum increments of rotation when navigating in 3D space.

Size of light: Varies the size of geometric shapes symbolizing different sizes and colors of lights.

Near clipping plane: The nearest distance visible in viewport.

Far clipping plane: The farthest distance visible in viewport.


Keyboard Shortcuts:

1. In Select mode, pressing Ctrl key selects multiple objects.

2. In move/rotate/scale mode pressing ALT selects objects.

3. In move/rotate/scale mode, pressing Ctrl or Shift adjusts increment size.

4. Pressing Shift + arrow keys adjusts increment size when moving/rotating camera.

 

System Requirements

Light Map Maker runs on Windows 98, Windows 2000,Windows XP, or Windows ME. (If you have a problem running Light Map Maker on your system, please contact us: techsupport@awingsoft.com, comments@awingsoft.com).
You will need a 3-D accelerator card and DirectX 8.1 installed.

 

Smoothing

no smoothing smoothing

Smoothing rounds sharp edges. LMM uses vertices-normals to accomplish this. To smooth, select a surface and check it's smoothing property. When importing models, if couldn't find normal data, LMM'll computer vertices-normals for every surface. At present, LMM supports importing of vertices-normals for the following 3D formats: AC3D, Wavefront OBJ, D3D X .


Radiosity

Radiosity is a method that simulates global illumination. 
Radisoty is rendering method that simulates global illumination. This lighting approach mimics realism perfectly. In LMM radiosity uses 3D accelerator hardware to improve performance. This  may case you CPU not full work when compute radiosity lighting; The advantage of this unique method is obvious: it saves a lot of time computing radiosity solutions for large scenes compared to the usual pure-soft algorithm.

Mirror

Mirror can reflect ray then cast bright mark. Any surface can  become a mirror by checking its Reflection property. And you can adjust reflection-intensity in the Edit Box in the back of "Reflection": . There is a option for turning on/off all mirrors in Light Map Option Dialog: .

Caustics

Caustics are light patterns that are created when light has been refracted by one or more surfaces. Only mobile can produce caustics in LMM. To render caustics, you should create a Material with the Generate Caustic checked beforehand, but first set a proper Refraction Index for it: . And you must set its Alpha component of diffuse color less than 255, to create transparence. Then assign this Material to a mobile. Next, create a light and check it's Generate Caustic property:. The Detail option controls the 
lights emission-density for caustics. Finally press F8 to actually render the caustics. You can render caustics for specific mobiles or lights by 
selecting them before rendering.

Refraction Indexes of familiar materials:

 Material  Refraction Index
 Vacuum  1.00000
 Air  1.00029
 Alcohols  1.32900
 Crown Glass  1.53000
 Crystal  2.00000
 Diamond  2.41700
 Emerald  1.57000
 Fused Quartz  1.46000
 Heavy Flint Glass  1.65000
 Glass  1.50000
 Ice  1.30900
 Quartz  1.64400
 Ruby/Sapphire  1.77000
 Salt  1.54400
 Sugar Solution (80%)  1.49000
 Sugar Solution (30%)  1.38000
 Topaz  1.61000
 Water  1.33333

 


www.awingsoft.com